Krijgt verborgen administratorsaccount niet meer zichtbaar

Stel hier uw vragen met betrekking tot Windows Vista
Plaats reactie
Gebruikersavatar
Leen
PC Web Plus - Member
PC Web Plus - Member
Berichten: 11
Lid geworden op: 03 feb 2014 15:16

#1

03 feb 2014 15:51

Hallo, ik heb een probleempje. Op de pc van mijn vrouw wilde ik op het inlogscherm de administratorsaccount verbergen.
Dit heb ik gedaan door volgens een tip in het register bij sleutel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList aan te maken de naam van de administratorsaccount met DWORD waarde 0. Zo gezegd, zo gedaan. Werkt prima, ware het niet dat het me nu niet meer lukt om de administratoraccount weer te voorschijn te halen. Volgens de toegepaste tip zou door in het aanmeldingsvenster te drukken op Ctrl+Alt+Del de mogelijkheid er zijn om de naam van de account en het bijbehorende wachtwoord op te geven. Niet dus! Geen welkomstscherm maar gelijk door naar het bureaublad van de gebruikersaccount. In de gebruikersaccount is er, zoals het ook hoort, echter geen mogelijkheid om weer terug te veranderen in het register.
Ook pogingen om de opdrachtpromp als administrator op te starten lukken niet omdat het invulvak voor wachtwoord en de Ja-knop niet actief zijn, alleen Annuleren is actief.
Wie weet raad?
Gebruikersavatar
Maxstar
Administrator
Administrator
Berichten: 41774
Lid geworden op: 27 sep 2008 10:18
Kennisniveau: (3) Expert
OS: Windows 10
AV: Emsisoft Anti-Malware
Contacteer:

#2

03 feb 2014 17:21

Hallo en welkom op het forum,

Ga eens naar start > uitvoeren en type het commando Control Userpasswords2 gevolgd door enter.
Staat er in het scherm wat nu opent een vinkje bij de optie "Gebruikers moeten een gebruikersnaam en wachtwoord opgeven om deze computer te kunnen gebruiken"?
Gebruikersavatar
Leen
PC Web Plus - Member
PC Web Plus - Member
Berichten: 11
Lid geworden op: 03 feb 2014 15:16

#3

04 feb 2014 12:12

Bedankt voor de reactie. Commando heb ik ingegeven, maar er opende, denk ik, een ander scherm dan je bedoelde, namelijk het Gebruikersaccountbeheer: "Uw toestemming is nodig om te kunnen doorgaan. Geef een administratorwachtwoord op en klik vervolgens op OK als u wilt doorgaan." En dan houdt het weer op, want het invulvak voor het wachtwoord en de OK-knop zijn beide niet actief. Er valt niets in te vullen (dat hoeft in dit geval ook niet, want er is geen administratorwachtwoord) maar maar OK-klikken gaat ook niet.
Gebruikersavatar
Maxstar
Administrator
Administrator
Berichten: 41774
Lid geworden op: 27 sep 2008 10:18
Kennisniveau: (3) Expert
OS: Windows 10
AV: Emsisoft Anti-Malware
Contacteer:

#4

04 feb 2014 12:28

Hallo,

Dan gaan we het even op een andere manier oplossen, je kan hiervoor gebruiken maken van een Kaspersky Rescue USB-stick.
Klik hier voor de handleiding om de USB-stick aan te maken.

Wanneer de computer is opgestart van deze USB-stick, zie je op het bureaublad het icoon van de Kaspersky Registry Editor.
Hiermee kan je de aangemaakte DWORD waarde weer uit het register verwijderen.
Gebruikersavatar
Leen
PC Web Plus - Member
PC Web Plus - Member
Berichten: 11
Lid geworden op: 03 feb 2014 15:16

#5

04 feb 2014 23:14

Het is gelukt!! Weliswaar niet met een USB-stick, dat pikte de BIOS nog niet. Een USB-stick herkent hij niet als removable disk. Daarom het ISO-bestand op een CD gebrand en dat werkte uitstekend. Hartelijk bedankt. Ik zat er wel mee.

Maar blijft over de vraag: wat ging er mis en wat moest anders, want de behoefte om de administratorlogin te verbergen is er nog steeds.
Gebruikersavatar
Maxstar
Administrator
Administrator
Berichten: 41774
Lid geworden op: 27 sep 2008 10:18
Kennisniveau: (3) Expert
OS: Windows 10
AV: Emsisoft Anti-Malware
Contacteer:

#6

05 feb 2014 09:12

Goedemorgen,

Mooi dat dit is gelukt, wat je kunt proberen om het administratoraccount te verbergen is om eerst het aanmeldscherm te veranderen.
Op de onderstaande wijze kan je instellen dat gebruikers altijd een gebruikersnaam moeten opgeven.
Op deze manier wordt de laatst gebruikte gebruikersnaam onthouden, dit is echter ook aan te passen zodat jet aanmeldvenster blanco is.
  • Ga eens naar start > uitvoeren en type het commando Control Userpasswords2 gevolgd door enter.
  • Staat er in het scherm wat nu opent een vinkje bij de optie "Gebruikers moeten een gebruikersnaam en wachtwoord opgeven om deze computer te kunnen gebruiken"?
Als dit is ingesteld kan je opnieuw de registertweak uitvoeren, maar ik weet niet of dat dan ook nog nodig is in jouw situatie.
Gebruikersavatar
Leen
PC Web Plus - Member
PC Web Plus - Member
Berichten: 11
Lid geworden op: 03 feb 2014 15:16

#7

05 feb 2014 23:30

Het is mij mooi gelukt weer in het zelfde probleem te geraken, alleen op een andere manier. Ik heb eerst het inlogscherm gewijzigd, zodat nu met Ctr+Alt+Del 'altijd' de accounts zichtbaar worden en er moet worden ingelogd.
Vervolgens heb ik het administratoraccount (de echte) zichtbaar gemaakt met commando net user administrator /active:yes met commandoprompt met adm.rechten. (ter info: er zijn 2 administratoraccounts + 1 gebruikersaccount) Het administratoraccount verbergen gaf ook geen enkel probleem, uiteraard met de aanduiding 'no'. Tenslotte ook het beheerdersaccount verborgen met hetzelfde commando. Om daarna te ervaren dat het beheerdersaccount of het administratoraccount (maakt niet uit welk) niet opnieuw zichtbaar zijn te maken door het oude probleem namelijk dat er geen toegang is tot de commandoprompt mét administratorrechten. Ook Kaspersky Rescue CD geeft in dit geval geen uitkomst zoals eerder, omdat er geen registertweak is die kan worden verwijderd. Alleen lijkt het mij dat het commando net user administrator ergens toch wel een wijziging in het register heeft gemaakt die zou kunnen worden hersteld, alleen waar?
Gebruikersavatar
Maxstar
Administrator
Administrator
Berichten: 41774
Lid geworden op: 27 sep 2008 10:18
Kennisniveau: (3) Expert
OS: Windows 10
AV: Emsisoft Anti-Malware
Contacteer:

#8

06 feb 2014 08:40

Goedemorgen,

Je had beter de registertweak kunnen gebruiken, die verbergt alleen het administratoraccount het commando wat je nu het gebruikt schakelt het gehele account uit.
In dit geval is er ook geen wijziging in het register die hieraan refereert maar is het een instelling in de policies van Windows.

De enige mogelijkheid om deze accounts nu weer in te schakelen is het gebruik van de Windows Vista recovery DVD.
Via de commandprompt kan je nu middels net user administrator /active:yes het administratoraccount weer inschakelen.
Gebruikersavatar
Leen
PC Web Plus - Member
PC Web Plus - Member
Berichten: 11
Lid geworden op: 03 feb 2014 15:16

#9

06 feb 2014 21:51

Helaas, dit had geen resultaat. Het commando werd wel uitgevoerd, tenminste die tekst verscheen na Enter, maar na opnieuw opstarten bleek toch alles het oude te zijn gebleven.
Gebruikersavatar
Maxstar
Administrator
Administrator
Berichten: 41774
Lid geworden op: 27 sep 2008 10:18
Kennisniveau: (3) Expert
OS: Windows 10
AV: Emsisoft Anti-Malware
Contacteer:

#10

08 feb 2014 11:57

Hallo,

De enige mogelijkheid is dan het aanpassen van de SAM data via de recovery console, op de onderstaande link staat beschreven hoe je dit kunt doen.
http://www.howtogeek.com/75470/how-to-e ... -registry/" onclick="window.open(this.href);return false;
Gebruikersavatar
Leen
PC Web Plus - Member
PC Web Plus - Member
Berichten: 11
Lid geworden op: 03 feb 2014 15:16

#11

10 feb 2014 22:56

Geprobeerd het register te wijzigen volgens de beschrijving van de gegeven link. Dat lukte niet omdat de SAM niet in het geheugen kon worden geladen. "Het proces heeft geen toegang tot het bestand omdat het door een ander proces wordt gebruikt" Ik heb geen idee wat dat zou kunnen zijn. Na wat googlen kwam ik een tip tegen om in de veilige modus op te starten waarbij dan de administratoraccount zou verschijnen. Dat klopte en ingelogd met de administratoraccount vervolgens de gebruikersaccount gewijzigd in een administratoraccount en opnieuw opgestart in normale mode. Ingelogd met de "gebruikersaccount" met administratorrechten (in de normale mode was de administratoraccount weer verborgen) de opdrachtprompt als administrator opgeroepen en het commando net user administrator /active:yes gegeven en het was weer in orde. Gelukkig. Voorlopig laat ik de administratoraccount maar zichtbaar.

Bedankt voor de hulp. Het was spannend, maar ik heb er heel wat van geleerd.
Gebruikersavatar
Maxstar
Administrator
Administrator
Berichten: 41774
Lid geworden op: 27 sep 2008 10:18
Kennisniveau: (3) Expert
OS: Windows 10
AV: Emsisoft Anti-Malware
Contacteer:

#12

11 feb 2014 08:11

Goedemorgen,

Bedankt voor de feedback en mooi dat het probleem op deze manier is verholpen... :good:
Plaats reactie

Terug naar “Windows Vista”

  • Informatie
  • Wie is er online

    Gebruikers op dit forum: Geen geregistreerde gebruikers en 1 gast