Pagina 1 van 1

Firefox plugins compatible maken met Firefox 4

Geplaatst: do 31 mar, 2011 12:50:56
door Forza
Elke plugin voor Firefox heeft een install.rdf bestand en hierin staat onder andere met welke versie van Firefox de plugin compatible is.
Dit bestand is te vinden in de volgende locatie op de hardeschijf waarop Windows is geïnstalleerd.

C:\Users\Gebruiker\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default\extensions
De map Gebruiker en xxxxxxxx.default zullen in uw geval een andere naam hebben, maar dat wijst zich vanzelf.

In een install.rdf bestand van een willekeurige add-on staat het volgende waarin de minimale versie en maximale versie van Firefox staan aangegeven.
Als een add-on niet comaptible is pas dan deze gegevens aan met de laatst beschikbare versiegegevens van Firefox.

 <!-- Firefox -->
        <em:targetApplication>
            <Description>
                <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
                <em:minVersion>3.0</em:minVersion>
                <em:maxVersion>4.0.*</em:maxVersion>
            </Description>
        </em:targetApplication>


Ook het bestand extensions.rdf moet je aanpassen met de laatste versiegegevens van Firefox, dit bestand is terug te vinden op de volgende locatie op de hardeschijf waarop Windows staat geïnstalleerd.

C:\Users\Gebruiker\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default

NS1:minVersion="1.0"
NS1:maxVersion="4.0.1"


Deze truc werkt ook bij oude plugins die je als XPI wil installeren want dit zijn gewoon ZIP die je gewoon kan uitpakken en of bijwerken met zowat ieder compressie programma.
Bewerk het install.rdf bestand en werkt het XPI / ZIP bestand bij en je kan ook deze oude add-on gewoon zonder problemen aan Firefox toevoegen. 8)

Voor Linux en MacOs gebruikers hier de path van de extensions.
•Linux: ~/.mozilla/firefox/xxxxxxxx.default\extensions\
•Mac OSX: Library/Application Support/Firefox/Profiles/xxxxxxxx.default/extensions/